Log in Sign up

Issue with resetting permalink structures

I’ve tried all three of the potential settings available at https://blot.im/settings/services/permalinks, but changing the setting and saving doesn’t seem to work as I might expect. My URLs default to the standard/original “Title” option.

Ideally I’d like to have permalinks be of the format https://example.com/foldername/filename which I would expect to work if I choose the “Custom” option and use the syntax {{path-without-extension}} in the field. However, this doesn’t seem to be the case. Am I doing something wrong, or is the setting just not saving and propagating properly?

From a documentation perspective, perhaps some examples of how to chain together the tokens on https://blot.im/how/configure/urls and the expected URL outputs might also be helpful for people?

Thanks in advance for your help.

2 replies Asked Apr 22 '22 at 0:24 · Improve this question

I confirm — I also have this issue and can't change the permalink template.

Update: It works. I forgot that I had Link property set in each file.

Answered Apr 25 '22 at 9:33 · Improve this answer

You shouldn't need to set a link property in each file, perhaps you ran into a bug? Please let us know if you think that is the case

Answered May 19 '22 at 18:13 · Improve this answer

Markdown allowed