Local Dev Environment Not Working

Hello, I've followed your instructions to get my local dev environment running, and it runs but then exits immediately. Checking the logs doesn't show me an error (that I can see) but it's like it shuts itself down immediately.

Here is the console output:


> Blot@0.0.0 local
> NODE_PATH=app node app/local

Local server capabilities:
- twitter embeds false
- markdown with pandoc  false
- .docx conversion  false
- .odt conversion  false
- dropbox client false
- persistent dashboard sessions  false

Visit your dashboard:
http://localhost:8080

Visit your blog:
http://localhost:8081

Open your blog's folder:
/Users/k/Projects/blot/tmp/example

[05/Oct/2022:16:14:46 -0600] Build: Launching new build worker overseer=32731
Setting up local client for blog_df93682d05104490ab8b0fe28f721887
Setup complete
[05/Oct/2022:16:14:47 -0600] Build: process pid=32734 launched
[05/Oct/2022:16:14:47 -0600] Build: process pid=32734 exiting...

And here is the log from my last run:

0 verbose cli [
0 verbose cli   '/Users/k/.nvm/versions/node/v16.14.0/bin/node',
0 verbose cli   '/Users/k/.nvm/versions/node/v16.14.0/bin/npm',
0 verbose cli   'run',
0 verbose cli   'local'
0 verbose cli ]
1 info using npm@8.3.1
2 info using node@v16.14.0
3 timing npm:load:whichnode Completed in 0ms
4 timing config:load:defaults Completed in 2ms
5 timing config:load:file:/Users/k/.nvm/versions/node/v16.14.0/lib/node_modules/npm/npmrc Completed in 1ms
6 timing config:load:builtin Completed in 1ms
7 timing config:load:cli Completed in 2ms
8 timing config:load:env Completed in 0ms
9 timing config:load:file:/Users/k/Projects/blot/.npmrc Completed in 0ms
10 timing config:load:project Completed in 2ms
11 timing config:load:file:/Users/k/.npmrc Completed in 0ms
12 timing config:load:user Completed in 0ms
13 timing config:load:file:/Users/k/.nvm/versions/node/v16.14.0/etc/npmrc Completed in 0ms
14 timing config:load:global Completed in 0ms
15 timing config:load:validate Completed in 0ms
16 timing config:load:credentials Completed in 1ms
17 timing config:load:setEnvs Completed in 1ms
18 timing config:load Completed in 13ms
19 timing npm:load:configload Completed in 13ms
20 timing npm:load:setTitle Completed in 5ms
21 timing config:load:flatten Completed in 3ms
22 timing npm:load:display Completed in 5ms
23 verbose logfile /Users/k/.npm/_logs/2022-10-05T22_14_45_810Z-debug-0.log
24 timing npm:load:logFile Completed in 6ms
25 timing npm:load:timers Completed in 0ms
26 timing npm:load:configScope Completed in 0ms
27 timing npm:load Completed in 31ms
28 silly logfile start cleaning logs, removing 1 files
29 timing command:run Completed in 1697ms
30 verbose exit 0
31 timing npm Completed in 1806ms
32 info ok
3 replies

Unfortunately I'm not going to provide support for running Blot in a local dev environment at this point – the guides and the code base will eventually be polished and I'll be in a better position to help debug this sort of problem. I hope you can understand that maintaining Blot for the long-term involves making decisions about where to allocate a finite amount of development time.

For what it's worth: I had a look through the output and whatever is going wrong is not obvious to me, unfortunately.

Answered 4 months ago · Improve this answer

Totally understandable - was hoping you saw something obvious. Thanks for taking a look! When I find the answer, I'll post it here to hopefully help out someone else with the same issue.

Answered 4 months ago · Improve this answer

I tried a couple different methods of installing node - and even thought maybe my Apple Silicon notebook was the issue and tried it on an older MacBook - no dice. If other users figure this out, please post here.

Answered 4 months ago · Improve this answer

Markdown allowed
Question or feedback?
Contact us

Tags

developers 28 questions bug 14 questions posts 9 questions resolved 7 questions request 6 questions google-drive 5 questions configure 4 questions pages 3 questions added 3 questions meta 3 questions More tags →
Subscribe for changes
RSS Feed of latest questions