Log in Sign up

Putting CloudFlare infront of blog

I noticed when enabling CloudFlare proxy, the site will end up in a redirect loop. This also happens when disabling the "Redirect subdomain on Blot to your custom domain" setting.

Anyone any luck with using CloudFlare proxy ontop of a blot blog?

11 replies Asked Dec 17 '21 at 8:56 · Improve this question

Are you using an apex domain? I think I experienced a similar issue using Cloudflare. My page would consistently take a long time to load. I'm not sure if it was due to a redirect loop, but it was noticeable.

I decided to use the www subdomain for now and create a redirect from the apex domain to the subdomain. However, I would much rather use the apex domain properly with Cloudflare, so hopefully there's a solution out there other than switching DNS providers.

Answered Dec 20 '21 at 23:58 · Improve this answer

Yeah correct, I'm using an apex domain as well. I just tried to use a www that's proxied (not just DNS) through cloudflare like you suggested and it isn't working as well. Getting the same "this page isn't redirecting correctly" as with the apex.

Answered Dec 21 '21 at 6:33 · Improve this answer

I checked again today and while I thought the www subdomain (also proxied) was working better, now today it looks to be just as slow as the apex was. So I'm not sure this solves the problem actually.

I don't get the "this page isn't redirecting correctly" error you're talking about though. Mine just loads very slowly (10+ seconds). I might try switching off Cloudflare and see if that helps, though I'd prefer to stay with Cloudflare.

Answered Dec 22 '21 at 22:12 · Improve this answer

To follow up: before switching over my existing domain I tested using a different domain I have with Namecheap and using Namecheap's DNS and using an ALIAS, it worked fine.

I'll be switching from Cloudflare to Namecheap for my DNS until this gets resolved.

Answered Dec 26 '21 at 6:27 · Improve this answer

I've also encountered issues with Cloudflare's flexible SSL option and Blot's redirect insecure traffic (HTTP to HTTPS) feature. They seem to trigger a redirect loop when combined, which sort of makes sense.

Answered Jan 18 '22 at 19:21 · Improve this answer

It also happens when the redirect option is turned off from my experience. Cloudflare proxy seems to not be compatible with blot currently, would be really nice if it were though!

Answered Jan 24 '22 at 7:53 · Improve this answer

I am so glad I found that thread. I am using Cloudflare and faced a similar problem of an extremely slow loading time (ie. 10 to 20 seconds). I will be moving out of Cloudflare but it will be great to have the Blot team look into this. I was wondering if the issue was with Blot first 👍

Answered Feb 27 '22 at 14:47 · Improve this answer

Cloudflare should work speedily if you disable either their HTTPS upgrade or Blot’s setting to redirect HTTPS

Answered Mar 1 '22 at 16:42 · Improve this answer

Oh wao! Have been stuck with trying to make blot.im work with Cloudflare for days, with no luck.

Just switched back to using Namecheap DNS servers and the custom domain works fine, within 5 mins.

Not being able to work with Cloudflare is a major issue -- should be documented to avoid future frustrated users.

Answered Apr 12 '22 at 21:07 · Improve this answer

Is anyone still having trouble with Cloudflare after doing one of the following?

The problem occurs when Cloudflare attempts to request content stictly over HTTP which it will then serve over HTTPS. Blot attempts to upgrade the request to HTTPS, which then triggers a redirect loop (Cloudflare insists on using HTTP for the source of some of their SSL options)

Answered Apr 15 '22 at 14:59 · Improve this answer

Disabling Blot's redirect worked for me. Thanks!

Answered Jun 3 '22 at 0:22 · Improve this answer

Markdown allowed